Вышел phpBBex 1.9.0, основанный на phpBB 3.0.13-PL1

Список разделов phpBBex 1.x Новости 1.x

Описание: Новости проекта phpBBex 1.x. Поддерживаются PHP 5.4+, 7.0+ и 8.0+.

  • 20

Сообщение #1 VEG » 20.02.2015, 15:21

Итак, вышел phpBB 3.0.13, а следом за ним — phpBB 3.0.13-PL1. Были исправлены некоторые неприятные ошибки. Новая версия phpBBex основана на этой версии phpBB. Также были сделаны некоторые улучшения.

Скачать: phpbbex-v1.9.0.zip (2.8 MiB, лицензия: GPL).

Требования:
  • PHP не ниже 5.2.3 с поддержкой Unicode в регулярных выражениях
  • MySQL не ниже 5.0.3

Что нового?

  • phpBB 3.0.13-PL1 в основе (со всеми его исправлениями)
  • Лайтбокс для картинок во вложениях
  • Улучшено кэширование style.php
  • Правильная нумерация сообщений в темах с закреплённым первым сообщением
  • Исправлен список городов в часовых поясах
  • Исправлена ошибочная отправка форм в админке при использовании автодополнения полей в браузере
  • Исправления в языковых файлах
  • jQuery 2.1.3 и MediaElement JS 1.16.3

Обновление c phpBBex 1.8.0 до 1.9.0

Если у вас более ранняя версия, сперва обязательно выполните инструкцию по обновлению до phpBBex 1.8.0. После этого выполните следующие инструкции.

  1. Сделайте резервную копию вашего сайта
  2. Замените все файлы (кроме config.php!) предыдущей версии phpBBex (или используйте Mercurial для автоматического сохранения ваших модов).
  3. Запустите install/database_update.php
  4. На данном этапе у вас должна быть база со схемой phpBBex 1.8.0. Сейчас выполните следующий SQL скрипт в вашей базе (при помощи PhpMyAdmin в панели вашего хостинга или другого подобного инструмента):
    Код: Выделить всё
    REPLACE INTO phpbb_config (config_name, config_value) VALUES ('phpbbex_version', '1.9.0');
  5. Не забудьте сбросить кэш в админке (на главной), обновить шаблоны, стили и наборы изображений.

Смотрите также


Спасибо, что вы с нами! :)
С наилучшими пожеланиями, Евгений
VEG M
Автор темы, Администратор
Аватара
Возраст: 34
Откуда: Минск, Беларусь
Репутация: 1635
С нами: 9 лет 7 месяцев

Сообщение #2 sag-sag » 20.02.2015, 21:09

Все отлично встало!
Заметки администратора [TEHADM.RU]
sag-sag M
Гуру
Аватара
Возраст: 35
Репутация: 411
С нами: 8 лет 3 месяца

Сообщение #3 Убивай » 20.02.2015, 21:53

чот боюсь пока что , по тренеруюсь пока на open servere
Убивай
Новичок
Репутация: 10
С нами: 6 лет 9 месяцев

Сообщение #4 rbooze » 21.02.2015, 00:23

Вроде работает
rbooze
Гуру
Аватара
Репутация: 95
С нами: 8 лет 3 месяца

Сообщение #5 ri4erson » 21.02.2015, 01:17

Поставилось все ровно, thanks.
ri4erson
Гость

Сообщение #6 Denka » 21.02.2015, 11:15

Все обновилось без проблем.
Да и копирайт после обновления внизу сменил дату, с 2013 на 2015 - радует :razz:

СПАСИБО Команде PHPBBEX!

Создано на основе phpBBex © 2015 phpBB Group, Vegalogic Software
Denka
Новичок
Репутация: 1
С нами: 6 лет 9 месяцев

Сообщение #7 pixxel » 21.02.2015, 12:45

Насколько критично для безопасности форума оставаться на версии 1.8 ?
pixxel
Новичок
Репутация: 0
С нами: 6 лет 10 месяцев

Сообщение #8 sag-sag » 21.02.2015, 13:09

pixxel, а почему не обновиться то!?
Заметки администратора [TEHADM.RU]
sag-sag M
Гуру
Аватара
Возраст: 35
Репутация: 411
С нами: 8 лет 3 месяца

Сообщение #9 pixxel » 21.02.2015, 13:34

sag-sag, переживаю в силу неопытности + моды.
Так на сколько все таки критично?
pixxel
Новичок
Репутация: 0
С нами: 6 лет 10 месяцев

Сообщение #10 sag-sag » 21.02.2015, 13:44

pixxel, сделай бекап сайта и обновись. Ну сказать что прям очень критично, нельзя. Но желательно
Заметки администратора [TEHADM.RU]
sag-sag M
Гуру
Аватара
Возраст: 35
Репутация: 411
С нами: 8 лет 3 месяца

  • 1

Сообщение #11 Sumanai » 21.02.2015, 15:01

pixxel:Насколько критично для безопасности форума оставаться на версии 1.8 ?
Вроде как злоумышленник может при стечении некоторых обстоятельств удалить всю вашу личку путём изменения настроек папок. Мелочь, в принципе.
Но лучше обновляться, потом проще бутет.
Использование поиска продлевает жизнь.
Это форум поддержки форка phpBBex. Поддержка по phpBB осуществляется в других местах.
Sumanai M
Гуру
Аватара
Репутация: 1677
С нами: 8 лет 10 месяцев

Сообщение #12 mfana » 21.02.2015, 22:40

Обнова встала без проблем, как влитая. :hi: Спасибо!
mfana M
Бывалый
Аватара
Возраст: 39
Откуда: ХМАО
Репутация: 17
С нами: 7 лет 8 месяцев

Сообщение #13 AllStars » 22.02.2015, 14:39

Ребята, напомните, как обновить, если у меня ни модов, ничего не установлено.
Mercurial тоже нет и не осилил его :)
Что надо сделать и как безболезненно обновить, чтоб все настройки сохранились?

Спасибо.
AllStars
Бывалый
Репутация: 1
С нами: 8 лет 2 месяца

  • 1

Сообщение #14 Sumanai » 22.02.2015, 15:02

AllStars, в первом сообщении этой темы большими буквами "Обновление c phpBBex 1.8.0 до 1.9.0", там всё подробно расписано.
Использование поиска продлевает жизнь.
Это форум поддержки форка phpBBex. Поддержка по phpBB осуществляется в других местах.
Sumanai M
Гуру
Аватара
Репутация: 1677
С нами: 8 лет 10 месяцев

Сообщение #15 hobot-bobot » 22.02.2015, 15:06

Опять вспоминать и учить команды Mercurial :smile:
ОАО "РЖД" - Редко Живу Дома
hobot-bobot M
Бывалый
Аватара
Откуда: Череповец
Репутация: 23
С нами: 8 лет 7 месяцев

Сообщение #16 rbooze » 22.02.2015, 16:27

hobot-bobot:Опять вспоминать и учить команды Mercurial

Я кстати это обновление накатил с помощью Sourcetree. Понравился клиент. А черепаха под мак полное гэ.
rbooze
Гуру
Аватара
Репутация: 95
С нами: 8 лет 3 месяца

Сообщение #17 gaborik » 22.02.2015, 20:12

Ручное обновление файлов phpBBex 1.8.0 до 1.9.0 будет? :smile:
gaborik
Новичок
Репутация: 1
С нами: 8 лет 10 месяцев

Сообщение #18 Sumanai » 22.02.2015, 20:16

В смысле? Пакетов обновления тут не выпускается. Если есть правки в файлах, намного проще воспользоваться Mercurial для обновления, чем полагаться на веб утилиту с очень ограниченным функционалом.
Использование поиска продлевает жизнь.
Это форум поддержки форка phpBBex. Поддержка по phpBB осуществляется в других местах.
Sumanai M
Гуру
Аватара
Репутация: 1677
С нами: 8 лет 10 месяцев

Сообщение #19 gaborik » 22.02.2015, 23:52

Sumanai:намного проще воспользоваться Mercurial для обновления,
Пытался обновить старый форум. Под конец вышло:
Безымянный.png

Как я понял проблема в трех файлов?
Как узнать в каких именно?

Добавлено спустя 34 секунды:
обновлял 1.7.1 на 1.8
gaborik
Новичок
Репутация: 1
С нами: 8 лет 10 месяцев

  • -1

Сообщение #20 Sumanai » 23.02.2015, 00:25

gaborik:Как узнать в каких именно?

Вам же написали- merging xxxxxx incomplete. В тех и смотрите.
Вообще, про Mercurial есть хорошая тема. Прочитайте, поймите, там всё хорошо описано.
Вопросы по системам контроля версий тоже нужно задавать там.
Использование поиска продлевает жизнь.
Это форум поддержки форка phpBBex. Поддержка по phpBB осуществляется в других местах.
Sumanai M
Гуру
Аватара
Репутация: 1677
С нами: 8 лет 10 месяцев

След.

Вернуться в Новости 1.x