Enable HTML

Список разделов phpBBex 1.x (поддерживается) Поддержка 1.x

Описание: У вас проблемы с phpBBex 1.x и вам необходима помощь? Спрашивайте здесь!
Правила раздела: Одна тема — один вопрос или группа связанных вопросов. Обязательно формируйте внятный заголовок, максимально отражающий суть вопроса. Подробно описывайте проблему. Не забудьте указать версию phpBBex и какие моды установлены, по возможности добавьте скриншоты проблемы или ссылку на страницу с проблемой.
Модератор: Поддержка

Сообщение #1 andrei » 14.02.2013, 23:44

Привет. Недавно установил мод Enable HTML, проверил, всё отлично работает, в правах доступа выставил разрешение только для админа в целях безопасности, но почему-то при заходе на форум в качестве гостя нельзя просматривать сообщения в темах. Сами заголовки сообщений в темах читаются, но если кликнуть по заголовку открывается пустая страничка вот с таким предупреждением:
Fatal error: Class 'auth' not found in /home/u612012817/public_html/includes/mods/enable_html.php on line 84
Когда заходишь на форум зарегистрированным такой же глюк, только он исчезает при обновлении страницы - нажимаешь "обновить страницу" и сообщение нормально открывается и ошибка уже больше не выскакивает. Я так понял в строке 84 что-то неверно вот тут:
Код: Выделить всё
 $new_auth = new auth();
      $new_auth->acl($user_row);
      $html_permissions[$user_id][$forum_id] = ($new_auth->acl_get('u_html') || $new_auth->acl_get('f_html', $forum_id)) ? true : false;
      unset($new_auth);
В чём может быть причина, подскажите пожалуйста, что тут неправильно? При установке мода возникло предупреждение что у меня устаревшая версия UMIL - может из-за этого?
phpbbex 1.7.1 + MySQL 5.5.25a + Apache 2.2.22 + PHP 5.3.14 + phpMyAdmin 3.5.1
Windows XP Pro
andrei M
Автор темы, Бывалый
Репутация: 1
С нами: 10 лет

Сообщение #2 VEG » 14.02.2013, 23:50

Код: Выделить всё
$new_auth = new auth();
замените на
Код: Выделить всё
$new_auth = new phpbb_auth();
VEG M
Администратор
Аватара
Возраст: 35
Откуда: Хельсинки, Финляндия
Репутация: 1649
С нами: 10 лет 9 месяцев

Сообщение #3 andrei » 15.02.2013, 00:05

VEG, Спасибо, помогло!
phpbbex 1.7.1 + MySQL 5.5.25a + Apache 2.2.22 + PHP 5.3.14 + phpMyAdmin 3.5.1
Windows XP Pro
andrei M
Автор темы, Бывалый
Репутация: 1
С нами: 10 лет

Сообщение #4 rvszap » 15.06.2014, 10:39

andrei, у Вас ошибка вылетает, когда вы хотите посмотреть профиль любого пользователя, клацая на его нике или нет.
вот пост с описанием проблемы /viewtopic.php?p=12708#p12708

Наверное данный мод просто не адаптирован под ех.
Какая у Вас версия ех стоит. Я смотрю что на сборке 1.6 постоянные проблемы. На 1.5.3 половины проблем, что правилось на 1.6 нет.
rvszap
Мастер
Репутация: 6
С нами: 9 лет 10 месяцев

Сообщение #5 sag-sag » 15.06.2014, 11:14

rvszap, ты посмотри дату его сообщения))
Заметки администратора [TEHADM.RU]
sag-sag M
Гуру
Аватара
Возраст: 36
Репутация: 411
С нами: 9 лет 5 месяцев


Вернуться в Поддержка 1.x