Выводит белиберду в админке

Список разделов phpBBex 1.x (поддерживается) Поддержка 1.x

Описание: У вас проблемы с phpBBex 1.x и вам необходима помощь? Спрашивайте здесь!
Правила раздела: Одна тема — один вопрос или группа связанных вопросов. Обязательно формируйте внятный заголовок, максимально отражающий суть вопроса. Подробно описывайте проблему. Не забудьте указать версию phpBBex и какие моды установлены, по возможности добавьте скриншоты проблемы или ссылку на страницу с проблемой.
Модератор: Поддержка

Сообщение #1 shrby » 16.12.2012, 19:54

Да бы не создавать новую тему, пишу сюда. В общем устрановил актуальную версию форума на хостинг hitex.by (VEG, надеюсь вам знаком он?), в общем перейдя в админку-Пользователи и группы-Управление группами-Предустановленные группы и если нажать на настройки вылазит окно такой вот ошибкой.
Изображение

Проблема хостинга или движка так и не понял.

UDP: Ошибка точная копия /viewtopic.php?p=773#p773
Но пробовал разными способами загружать файлы, в итоге нечего не помогло.
shrby M
Автор темы
Откуда: Беларусь
Репутация: 0
С нами: 12 лет

Сообщение #2 VEG » 16.12.2012, 23:26

shrby:на хостинг hitex.by (VEG, надеюсь вам знаком он?)
Нет, я не знаком со всеми мелкими хостингами на планете :) С белорусскими хостерами решил больше никогда не связываться. Качество хромает при немалых ценах. Работал со swisshost.by (самый негативный опыт), extmedia.by (очеь слабый хостер), немного hoster.by. Из тройки гигантов российского хостинга пробовал nic.ru, masterhost.ru и hc.ru — самым гибким и удобным оказался nic.ru. Самый лучший из shared хостингов что я видел, во многом гибкий как VPS (можно ставить любые модули Apache самостоятельно).
shrby:Проблема хостинга или движка так и не понял.
Скорее всего какая-то проблема с хостингом, поскольку я проблему повторить не смог. Скорее всего на сервер загружаются битые скрипты. Попробуйте загружать файлы на хостинг при помощи Total Commander последней версии (не сборки, а оригинальной версией). С подобными проблемами сталкивались пользователи при загрузке при помощи FileZilla.
Самым надёжным способом загрузки будет загрузка архива движка по SFTP и извлечение его прямо на сервере командой unzip через SSH.

Добавлено спустя 2 минуты 23 секунды:
Также уточните, какая у вас версия PHP — возможно, слишком старая. Как крайний случай можно отключить вывод ошибок — возможно, видимость проблемы это решит, но проблема останется и какая-то часть движка будет работать не так как положено.
VEG M
Администратор
Аватара
Откуда: Finland
Репутация: 1661
С нами: 12 лет 2 месяца

Сообщение #3 shrby » 17.12.2012, 10:58

С этой ошибкой не разу не сталкивался. Даже на Denwer, Open-Server подобных проблем не было.
P.s. Думаете я не заливал файлы разными FTP клиентами? Пробовал всё, даже браузером а толку 0.
Изображение
Так настроен домен. Больше не каких особых настроек нету. Панель управления Plesk.
Да кстати в ЛС скинул ссылку о php.

UDP: Хостер отписал
что если чего то для работы не хватает то думаю смогу до установить.

Вот куда копать и в чём причина не пойму. :insane:
shrby M
Автор темы
Откуда: Беларусь
Репутация: 0
С нами: 12 лет

Сообщение #4 VEG » 17.12.2012, 15:09

shrby, посмотрел ваше phpinfo.
У вас стоит PCRE Library Version 6.6 06-Feb-2006 (это библиотека для работы с регулярными выражениями). Это очень, очень, очень старая версия, которая не поддерживает Unicode. Не знаю где ваш хостер её откопал. Необходимо пересобрать PHP с более новой версией PCRE. У меня на хостинге стоит, например, версия 8.12 2011-01-15. Точно минимально необходимую версию PCRE не скажу — обычно при установке новых PHP используются свежие версии PCRE. У вас же стоит PHP 5.3 с PCRE времён, когда PHP 5.3 даже в проекте не было. Следует попросить вашего хостера обновить PHP со всеми его внутренними компонентами до актуального состояния.

Добавлено спустя 1 минуту 27 секунд:
Если админ у хостинга сговорчивый, можете сразу просить обновление до свежайшей версии PHP 5.4 и всех сопутствующих компонентов :)
VEG M
Администратор
Аватара
Откуда: Finland
Репутация: 1661
С нами: 12 лет 2 месяца

Сообщение #5 shrby » 17.12.2012, 15:21

VEG
Отписал в support, надеюсь "пойдут на встречу" и помогут решить проблему. Так как жутко не хочу ставить форум phpbb :zombie:

Получил ответ:
Данное обновление затронет всех клиентов хостинга. Ради 1 го я на такое пойти не могу. Потому как не факт что у всех текущих скрипты станут верно работать на новой версии. Увы, нужен другой вариант.

Если не найти решение, то придётся уйти с данного хостинга, и платить в 1.5 раза больше за подобный тариф, что сейчас на hitex.by :sad:
shrby M
Автор темы
Откуда: Беларусь
Репутация: 0
С нами: 12 лет

Сообщение #6 VEG » 17.12.2012, 15:43

shrby, пускай тогда хотя бы обновят PCRE на версию с поддержкой Unicode и UTF-8, собрав ту же версию PHP. Это никак не повлияет на работу существующих скриптов, зато у всех клиентов появится поддержка Юникода в регулярных выражениях. Можно, конечно, вырезать из регулярок все юникодные символы. Они используются для поддержки русскоязычных урлов и для пары других не очень критичных мелочей. Но это уже слишком радикальный метод :)
VEG M
Администратор
Аватара
Откуда: Finland
Репутация: 1661
С нами: 12 лет 2 месяца

Сообщение #7 NO SWEAR » 18.12.2012, 12:52

shrby, переходите на другого хостера. и проблемы пропадут. сам уже больше года на нем и таких проблем не было. все версии скриптов содержат в актуальном состоянии. и упрашивать обновлять никого не надо будет.
NO SWEAR M
Аватара
Репутация: 115
С нами: 11 лет 9 месяцев

Сообщение #8 shrby » 18.12.2012, 19:38

VEG Вот, что написал хостер.

Код: Выделить всё
Так, результату не оказались успешными. После пересборки php 5.3.3 c новой версией PCRE отказывается заводится веб интерфейс самой хостинг панели plesk по каким то причинам.
--
С уважением,
Алексей | support@hitex.by
shrby M
Автор темы
Откуда: Беларусь
Репутация: 0
С нами: 12 лет

Сообщение #9 factotum » 18.12.2012, 21:57

shrby:хостинг *.by
какой то страшный сон :insane:
factotum
Откуда: Люксембург
Репутация: 234
С нами: 12 лет 2 месяца

Сообщение #10 VEG » 19.12.2012, 11:51

shrby:Так, результату не оказались успешными. После пересборки php 5.3.3 c новой версией PCRE отказывается заводится веб интерфейс самой хостинг панели plesk по каким то причинам.
Поддержка Unicode никак не должна как-то мешать вообще хоть каким-либо скриптам. Забавно, что хостер такое написал :) Видимо, толкового админа нет, и собрать новый PHP со всеми необходимыми модулями не получилось. В таком случае остаётся два варианта:
1. Сборка и запуск нужной версии PHP в режиме CGI — это позволит поменять PHP только для вашего сайта, не затрагивая панель и другие сайты. Не годится для форумов с большим количеством посетителей, ибо это медленно.
2. Выбор хостинга с нормальным PHP. На хороших хостингах у вас должна быть возможность поставить нужную версию PHP самостоятельно в режиме mod_php без затрагивания соседних площадок других пользователей. Какой у вас тарифный план на hitex? Может быть подскажем что-нибудь подходящее.
VEG M
Администратор
Аватара
Откуда: Finland
Репутация: 1661
С нами: 12 лет 2 месяца

Сообщение #11 shrby » 19.12.2012, 12:38

VEG:Какой у вас тарифный план на hitex? Может быть подскажем что-нибудь подходящее.
Все не много проще, буквально дня 3-4 назад, hitex проводил акцию, то сть можно было получить тариф "Позитив NIX" бесплатно на месяц, используя промо-код. Чем я и воспользовался, сейчас я в принципе рад, что не платил за хостинг, так как было бы очень обидно. Чо касается тарифа и других хостеров, то "подобный тариф как на hitex у других стоит как правило в 1 - 1.5 - 2 раза дороже. Поэтому на данном этапе думаю, как лучше поступить.

P.s. Hitex в принципе не плохой хостер (знаю уже не первый год), но вот обидно то, что они пользуются старым "багнутым ПО" для "веб-сервера" + как я понял, желание использовать актуальное ПО, то же не хотят. :zombie:
shrby M
Автор темы
Откуда: Беларусь
Репутация: 0
С нами: 12 лет

Сообщение #12 factotum » 19.12.2012, 13:14

shrby:то "подобный тариф как на hitex у других стоит как правило в 1 - 1.5 - 2 раза дороже
приглядитесь к этому: http://www.hetzner.de/en/hosting/produktmatrix/webhosting-produktmatrix
Level 4 » безлимитный канал, 4 GB дискового пространства, 5 доменов, 400 субдоменов, 10 баз MySQL/PostgreSQL. Все это стоит 4,90евро в месяц и вполне достаточно, чтобы крутить до 20 ресурсов с общей посещаемостью до 10К в день. Ну и отказоустойчивые сервера с мониторингом в реальном режиме времени и цивилизованным подходом к делу только в плюс.
factotum
Откуда: Люксембург
Репутация: 234
С нами: 12 лет 2 месяца

Сообщение #13 shrby » 19.12.2012, 14:29

factotum
Если бы нужен хостинг зарубежом, то давно бы заказал у знакомого хостера. Но хостинг интересует только в Беларуси (связано с дебильным указаном страны).
shrby M
Автор темы
Откуда: Беларусь
Репутация: 0
С нами: 12 лет

Сообщение #14 VEG » 19.12.2012, 16:11

shrby, так у вас, выходит, интернет-магазин? Тот ведь указ касается только некоторых типов веб-сайтов.
VEG M
Администратор
Аватара
Откуда: Finland
Репутация: 1661
С нами: 12 лет 2 месяца

Сообщение #15 shrby » 19.12.2012, 16:14

VEG:так у вас, выходит, интернет-магазин? Тот ведь указ касается только некоторых типов веб-сайтов.
Нет. Нужен форум "для так сказать предприятия". Да и вообще, если например, вы предоставляете услуги для жителей Беларуси, ваш ресурс обязан находиться в Беларуси.
P.s. Если найду сам указ, скину ссылку.

Добавлено спустя 5 минут 9 секунд:
UDP
Если правильно помню, то вот сам указ.
shrby M
Автор темы
Откуда: Беларусь
Репутация: 0
С нами: 12 лет

Сообщение #16 VEG » 19.12.2012, 16:23

У меня из белорусских форумов есть только slutsk.net, он физически в Беларуси никогда не хостился. Что-то мне подсказывает, что никто серьёзно не следит за соблюдением этого указа. google.by явно находится за пределами Беларуси — и у Google с этим явно проблем нет :) Это же касается и других компаний, у которых домены во многих доменных зонах.
Если не секрет, о каком сайте идёт речь?
VEG M
Администратор
Аватара
Откуда: Finland
Репутация: 1661
С нами: 12 лет 2 месяца

Сообщение #17 factotum » 19.12.2012, 17:29

VEG:Что-то мне подсказывает, что никто серьёзно не следит за соблюдением этого указа.
очень интересно, как указ может достать slutsk.net или, например, этот неоднозначный ресурс
factotum
Откуда: Люксембург
Репутация: 234
С нами: 12 лет 2 месяца

Сообщение #18 alf » 28.12.2014, 11:06

Доброго времени суток.

Перешел с phpBB на phpBBex, понравился конечно phpBBex но...

При нажатии кнопки правка - открывается пустое поле где должен содержаться старый текст сообщения.
+ ошибка
Код: Выделить всё
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions_content.php on line 387: preg_replace(): Compilation failed: unrecognized character after (? at offset 2

При внесении нового сообщения вносит нормально.

Тоже у хостера PCRE Library Version 6.6 06-Feb-2006 толковых админов у них нет ,менять хостинг не хочу .

Подскажите где править, чтоб вернутся к функционалу phpBB при нажатии кнопки правка, пускай без наворотов phpBBex отображения кирилистических URL и прочего

function decode_message которая находится на line 387 phpBBex идентичная и в файле phpBB.

Где копать?
alf
Репутация: 2
С нами: 9 лет 6 месяцев

Сообщение #19 Test » 28.12.2014, 12:32

alf:Где копать?
Хостер должен обновить PHP, как это было уже выше сказано.
Test
Гость

Сообщение #20 alf » 28.12.2014, 15:04

У хостера толковых админов нет(и у них не получается :zombie: ) .
С хостинга уходить не хочется.

Меня интересует, что в конфигурации phpbbex можно поменять , чтобы "регулярки" phpbbex перевести на более старую версию "регулярок" phpbb3 -там всё работало без вопросов.
alf
Репутация: 2
С нами: 9 лет 6 месяцев

След.

Вернуться в Поддержка 1.x