Загруженный файл пустой

Board index phpBBex 1.x Поддержка

Description: У вас проблемы с phpBBex 1.x и вам необходима помощь? Спрашивайте здесь!
Forum rules: Одна тема — один вопрос или группа связанных вопросов. Обязательно формируйте внятный заголовок, максимально отражающий суть вопроса. Подробно описывайте проблему. Не забудьте указать версию phpBBex и какие моды установлены, по возможности добавьте скриншоты проблемы или ссылку на страницу с проблемой.
Moderator: Поддержка

Post #1by sag-sag » 28.03.2015, 12:25

Загружаю файл 600мб
Вываливается сообщение:
Screenshot_1.png

php.ini:
Code: Select all
upload_max_filesize = 700M
Code: Select all
post_max_size = 700M
Заметки администратора [TEHADM.RU]
sag-sag M
Topic author, Гуру
Avatar
Age: 33
Reputation: 399
With us: 6 years 3 months

Post #2by Sumanai » 28.03.2015, 13:03

Может времени исполнения скрипта не хватает?
Использование поиска продлевает жизнь.
Это форум поддержки форка phpBBex. Поддержка по phpBB осуществляется в других местах.
Sumanai M
Гуру
Avatar
Reputation: 1667
With us: 6 years 9 months

Post #3by Test » 28.03.2015, 15:03

Настройки плагинов/расширений защиты проверь, например suhosin.
Test
Гость

Post #4by sag-sag » 04.08.2015, 00:23

Опять та же проблема. Файлы больше 500 мб не грузятся.
php.ini
Code: Select all
upload_max_filesize   2000M

nginx.conf
Code: Select all
client_max_body_size 512m

Причем тогда я решил эту проблему. Как вот так и не понял. Но вроде все зависит от my.cnf.
Spoiler
Code: Select all
Server globals
user                    www-data;
worker_processes        2;
error_log               /var/log/nginx/error.log;
pid                     /var/run/nginx.pid;


# Worker config
events {
        worker_connections  1024;
        use                 epoll;
}


http {
    # Main settings
    sendfile                        on;
    tcp_nopush                      on;
    tcp_nodelay                     on;
    client_header_timeout           1m;
    client_body_timeout             1m;
    client_header_buffer_size       2k;
    client_body_buffer_size         256k;
    client_max_body_size            1000m;
    large_client_header_buffers     4   8k;
    send_timeout                    30;
    keepalive_timeout               60 60;
    reset_timedout_connection       on;
    server_tokens                   off;
    server_name_in_redirect         off;
    server_names_hash_max_size      512;
    server_names_hash_bucket_size   512;


    # Log format
    log_format  main    '$remote_addr - $remote_user [$time_local] $request '
                        '"$status" $body_bytes_sent "$http_referer" '
                        '"$http_user_agent" "$http_x_forwarded_for"';
    log_format  bytes   '$body_bytes_sent';
    #access_log          /var/log/nginx/access.log  main;
    access_log off;

Может кто сможет помочь?
Заметки администратора [TEHADM.RU]
sag-sag M
Topic author, Гуру
Avatar
Age: 33
Reputation: 399
With us: 6 years 3 months

Post #5by sag-sag » 14.08.2015, 14:46

Проблему наконец-то решил:
Бывает, что нужно указать для параметра upload_tmp_dir место с достаточным объёмом. Так как по умолчанию идет запись во временный каталог, обычно в /tmp, а он обычно является tmpfs, т.е. находится в оперативной памяти, которой видимо и не хватает.
Чтоб это исправить дописываем:
Code: Select all
upload_tmp_dir = /var/tmp
Заметки администратора [TEHADM.RU]
sag-sag M
Topic author, Гуру
Avatar
Age: 33
Reputation: 399
With us: 6 years 3 months


Return to Поддержка



Who is online (over the past 10 minutes)

Users browsing this forum: 1 guest

cron