Принудительный переход с HTTP нa HTTPS и ошибка из-за этого.

Board index phpBBex 1.x Поддержка

Description: У вас проблемы с phpBBex 1.x и вам необходима помощь? Спрашивайте здесь!
Forum rules: Одна тема — один вопрос или группа связанных вопросов. Обязательно формируйте внятный заголовок, максимально отражающий суть вопроса. Подробно описывайте проблему. Не забудьте указать версию phpBBex и какие моды установлены, по возможности добавьте скриншоты проблемы или ссылку на страницу с проблемой.
Moderator: Поддержка

Post #1by Jonathan McKenzie » 06.06.2019, 10:27

Приветствую вновь! Сегодня лазил по настройкам в админ. панели, заметил, что у меня по дефолту стоит http, хотя у меня имелся SSL-сертификат, но установить его я забыл. Ну так вот, я принудительно переключил форум на https и сейчас я не могу зайти как на форум, так и в администраторскую панель. :think:

Added after 6 hours 19 minutes:
Вот что показывает при переходе на форум:
Spoiler
Image
Jonathan McKenzie
Topic author, Гость

Post #2by Sumanai » 06.06.2019, 19:05

Jonathan McKenzie wrote:Ну так вот, я принудительно переключил форум на https
Что именно вы настраивали?
Необходимо сменить настройки Cookies, Протокол сервера, Порт сервера. Вы наверняка забыли сменить порт, это видно из адресной строки.

Added after 1 minute 42 seconds:
Вообще, на своём я ничего не настраивал, только прописал редирект силами веб-сервера. Если не стоят принудительные настройки, а они не стоят по умолчанию, то всё должно было работать без дополнительных телодвижений.
Использование поиска продлевает жизнь.
Это форум поддержки форка phpBBex. Поддержка по phpBB осуществляется в других местах.
Sumanai M
Гуру
Avatar
Reputation: 1666
With us: 6 years 8 months

Post #3by Jonathan McKenzie » 07.06.2019, 05:07

Я зашел в админ. панель в раздел "Настройки сервера" и сделал так, чтобы при переходе на форум он автоматически менял протокол HTTP на HTTPS и после этого вылезла ошибка.

Added after 1 minute 27 seconds:
Я просто так и не понял, что мне в таком случае делать? Форум нужен сильно, а я криворукий и все испоганил.

Added after 2 minutes 28 seconds:
Sumanai wrote:
Jonathan McKenzie wrote:Ну так вот, я принудительно переключил форум на https
Если не стоят принудительные настройки, а они не стоят по умолчанию, то всё должно было работать без дополнительных телодвижений.
Они как раз-таки и стоят. Есть ли возможность как то "дистанционно" их отрубить, не залезая в кукис и прочее? Просто это все очень геморрно, а я уже и так достаточно вымотался из-за форума.

Added after 7 minutes 16 seconds:
А, все, решил проблему. В общем, я зашел снова на свой форум, мне выдало снова ту же ошибку, я зашел в адресную строку, поменял все на "http://pd-sf.ru/index.php". Я зашел под своим аккаунтом, снова выбило ошибку. Убираем из pd-sf.ru:80 двоеточие и цифры, ставим заместо "https" "http" и так мы логинимся. Нажимаем "админка", делаем все тоже самое, что я и написал ранее и мы под ней. Дальше же без каких либо проблем настраиваем форум. :smoke: :biggrin:
Jonathan McKenzie
Topic author, Гость

Post #4by Sumanai » 07.06.2019, 17:42

Можете написать на почту sumanai@ya.ru, посмотрю и сделаю за "на пиво".
Использование поиска продлевает жизнь.
Это форум поддержки форка phpBBex. Поддержка по phpBB осуществляется в других местах.
Sumanai M
Гуру
Avatar
Reputation: 1666
With us: 6 years 8 months


Return to Поддержка