phpBB [media]: one bbcode for audio, video, maps, panoramas, etc.

Board index phpBBex in English General

Description: General discussion about phpBBex
Moderator: Поддержка

Post #21by VEG » 30.06.2014, 20:34

eirki, check your page for JS errors. Any JS error on your page stops execution of JavaScript on your pages. BB [media] can't work without it.
С наилучшими пожеланиями, Евгений
VEG M
Topic author, Администратор
Avatar
Age: 29
Location: Минск, Беларусь
Reputation: 1607
With us: 4 yaers 10 months

Post #22by kuko61 » 22.10.2014, 21:05

Hallo, i add [media] BBcode to our forum. Embedding works well, except google panoramas.
There is a possibility to embed panoramas from Google maps?
URL examples:
Code: Select all
https://www.google.com/maps/views/u/0/view/115913791291134036336/gphoto/6063143057338202850?gl=us&heading=40&pitch=90&fovy=90
https://www.google.sk/maps/@48.1430761,16.9490082,3a,90y,84.09h,89.27t/data=!3m5!1e1!3m3!1sZ40NsVmmpp0AAAQW-a1yDA!2e0!3e11
Thank you
kuko61
Гость

Post #23by VEG » 03.11.2014, 12:43

kuko61, I've added this type of URLs in my TODO list.
С наилучшими пожеланиями, Евгений
VEG M
Topic author, Администратор
Avatar
Age: 29
Location: Минск, Беларусь
Reputation: 1607
With us: 4 yaers 10 months

Post #24by Douglas3362 » 28.12.2015, 14:12

Hi,
:help:
Don't work with Garmin Connect...
Do you work on an update?
Douglas3362
Гость

Post #25by Sumanai » 28.12.2015, 15:19

Sorry, but the author had not updated bbсode, afraid to add support for new services it will not be.
Использование поиска продлевает жизнь.
Это форум поддержки форка phpBBex. Поддержка по phpBB осуществляется в других местах.
Sumanai M Online
Гуру
Avatar
Reputation: 1502
With us: 4 yaers

Post #26by sina92 » 14.01.2016, 20:14

I can't figure out how to embed an .mp4 attachment into my post on my phpbb forum.

I've followed this great guide guide: /viewtopic.php?t=29, but unfortunately it doesn't apply to attached .mp4 files it seems.

[media]http: //blablabla[/media] works for videos on the internet, but what should I write if I want to embed an attached video?

xxxx.mp4
gives me a plug in error.

Anyone has any idea?

Best regards
sina92
Новичок
Reputation: 0
With us: 1 year 1 month

Post #27by Guest » 20.01.2016, 03:21

phpBB [media]
Guest
Гость

Post #28by voomm » 01.08.2016, 00:16

Hi!
I use the bbmedia.js in Version 1.0 from 2012 in a phpBB 3.1.9 Forum and it works nicely. In order to get all those new additions working I installed the new version 1.69 but now for any embed I get "Invalid BBCode" error message. I replaced the old BBCode with the one from this thread and I tried including the js locally as well as from the phpbbex-URL. Any idea what might go wrong?
Greetings, voom
voomm
Гость

Post #29by Sumanai » 01.08.2016, 00:28

Can you provide a link to the message witch error?
Использование поиска продлевает жизнь.
Это форум поддержки форка phpBBex. Поддержка по phpBB осуществляется в других местах.
Sumanai M Online
Гуру
Avatar
Reputation: 1502
With us: 4 yaers

Post #30by RrrrobbbB » Yesterday, 21:37

When I implement both [Media] and [Media=] to my board, the [Media] won't work again after [Media=] has been used. Not even deleting the post with the [Media=] will repair the ones with just [Media]. It seems that the server regards them not as two different functions, but one, and that [Media=] has overwritten [Media]

Earlier today I had a similar problem with [VIDEO] and [VIDEO=].

Is there a way to fix this? (I can think of a workaround but that's not a neat solution. People should be able to use [Media] both as it is and with specified dimensions.

Oh, my board uses phpBB v. 3.2
RrrrobbbB
Гость

Post #31by Sumanai » Yesterday, 23:46

RrrrobbbB wrote:Oh, my board uses phpBB v. 3.2
Use XSLT, see:
https://area51.phpbb.com/phpBB/viewtopic.php?t=44467&start=150#p298531
Использование поиска продлевает жизнь.
Это форум поддержки форка phpBBex. Поддержка по phpBB осуществляется в других местах.
Sumanai M Online
Гуру
Avatar
Reputation: 1502
With us: 4 yaers

Post #32by RrrrobbbB » Today, 01:08

Hey thanks that actually works!!

Code: Select all
[media={INTTEXT;optional}]{URL}[/media]

Code: Select all
<xsl:choose>
   <xsl:when test="@*">
      <div class='bbmedia' data-url='{URL}' data-args='{INTTEXT}' style='margin: 1px; display: inline-block; vertical-align: bottom;'><div style='width: 200px; height: 40px; border: 1px solid #999; display: table-cell; text-align: center; vertical-align: middle; font: 10px/10px Verdana; color: #555; opacity: 0.5;'><a style='color: #105289; text-decoration: none;' href='http://phpbbex.com/' target='_blank'>phpBB</a> &#91;media&#93;</div><script>if (typeof bbmedia == 'undefined') { bbmedia = true; var e = document.createElement('script'); e.async = true; e.src = 'http://phpbbex.com/api/bbmedia.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(e, s); }</script></div>
   </xsl:when>
   <xsl:otherwise>
      <div class='bbmedia' data-url='{URL}' style='margin: 1px; display: inline-block; vertical-align: bottom;'><div style='width: 200px; height: 40px; border: 1px solid #999; display: table-cell; text-align: center; vertical-align: middle; font: 10px/10px Verdana; color: #555; opacity: 0.5;'><a style='color: #105289; text-decoration: none;' href='http://phpbbex.com/' target='_blank'>phpBB</a> &#91;media&#93;</div><script>if (typeof bbmedia == 'undefined') { bbmedia = true; var e = document.createElement('script'); e.async = true; e.src = 'http://phpbbex.com/api/bbmedia.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(e, s); }</script></div>
   </xsl:otherwise>
</xsl:choose>

The only somewhat bothering fact is that now the button is called media= instead of just media. I tried to get rid of the space before the = by insterting a space in the code before it (media =) but that renders the tag non-functioning.

Is there way to set how the tag appears in the Posting Page interface? (It would also be cool to have an icon instead of the text, but I suppose that is virtually impossible.)

Added after 5 minutes 32 seconds:
PS It *did* work, but now it doesn't anymore. Weird. Maybe I damaged the code by copying it.
RrrrobbbB
Гость

Post #33by Sumanai » Today, 03:02

RrrrobbbB wrote:PS It *did* work, but now it doesn't anymore. Weird. Maybe I damaged the code by copying it.
This code works for me. Maybe, your site work on HTTPS?
Использование поиска продлевает жизнь.
Это форум поддержки форка phpBBex. Поддержка по phpBB осуществляется в других местах.
Sumanai M Online
Гуру
Avatar
Reputation: 1502
With us: 4 yaers

Previous

Forum name: General
Description: General discussion about phpBBex

Quick reply


Enter the code exactly as it appears. All letters are case insensitive.
Confirmation code
:hi: :smile: :wink: :twisted: :sad: :evil: :smoke: :eh: :eek: :fie: :silenced: :razz: :oops: :help: :spy: :insane: :biggrin: :toothless: :ill: :nervious: :weirdface: :pray: :clap: :think: :boxing: :cyclop: :rambo: :zombie: :cry: View more smilies

   

Return to General